What’s Vulnerable › Vulnerabilities
CVE-2021-24925: Modern Events Calendar Lite < 6.1.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Modern Events Calendar Lite WordPress plugin before 6.1.5 does not sanitise and escape the current_month_divider parameter of its mec_list_load_more AJAX call (available to both unauthenticated and authenticated users) before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue
Affected products
- Modern Events Calendar Lite: before 6.1.5 — fixed in 6.1.5
How to fix
Upgrade to a fixed version: Modern Events Calendar Lite 6.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/82233588-6033-462d-b886-a8ef5ee9adb0
- https://wpscan.com/vulnerability/82233588-6033-462d-b886-a8ef5ee9adb0
Get alerted when CVE-2021-24925 or the next vulnerability affects your stack