What’s Vulnerable › Vulnerabilities
CVE-2021-24926: Domain Check < 1.0.17 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Domain Check WordPress plugin before 1.0.17 does not sanitise and escape the domain parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting issue
Affected products
- Domaincheckplugin Domain Check: before 1.0.17 — fixed in 1.0.17
How to fix
Upgrade to a fixed version: Domaincheckplugin Domain Check 1.0.17. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8cc7cbbd-f74f-4f30-9483-573641fea733
- https://wpscan.com/vulnerability/8cc7cbbd-f74f-4f30-9483-573641fea733
Get alerted when CVE-2021-24926 or the next vulnerability affects your stack