What’s Vulnerable › Vulnerabilities
CVE-2021-24928: Rearrange Woocommerce Products < 3.0.8 - Subscriber+ SQL Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-89
Description
The Rearrange Woocommerce Products WordPress plugin before 3.0.8 does not have proper access controls in the save_all_order AJAX action, nor validation and escaping when inserting user data in SQL statement, leading to an SQL injection, and allowing any authenticated user, such as subscriber, to modify arbitrary post content (for example with an XSS payload), as well as exfiltrate any data by copying it to another post.
Affected products
- Rearrange Woocommerce Products: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: Rearrange Woocommerce Products 3.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3762a77c-b8c9-428f-877c-bbfd7958e7be
- https://wpscan.com/vulnerability/3762a77c-b8c9-428f-877c-bbfd7958e7be
Get alerted when CVE-2021-24928 or the next vulnerability affects your stack