What’s Vulnerable › Vulnerabilities
CVE-2021-24934: Visual CSS Style Editor < 7.5.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Visual CSS Style Editor WordPress plugin before 7.5.4 does not sanitise and escape the wyp_page_type parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting issue
Affected products
- Visual CSS Style Editor: before 7.5.4 — fixed in 7.5.4
How to fix
Upgrade to a fixed version: Visual CSS Style Editor 7.5.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2649978
- https://wpscan.com/vulnerability/0aa5a8d5-e736-4cd3-abfd-8e0a356bb6ef
- https://plugins.trac.wordpress.org/changeset/2649978
- https://wpscan.com/vulnerability/0aa5a8d5-e736-4cd3-abfd-8e0a356bb6ef
Get alerted when CVE-2021-24934 or the next vulnerability affects your stack