What’s Vulnerable › Vulnerabilities
CVE-2021-24935: WP Google Fonts < 3.1.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Google Fonts WordPress plugin before 3.1.5 does not escape the googlefont_ajax_name and googlefont_ajax_family parameter of the googlefont_action AJAx action (available to any authenticated user) before outputing them in attributes, leading Reflected Cross-Site Scripting issues
Affected products
- WP Google Fonts: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: WP Google Fonts 3.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2623659
- https://wpscan.com/vulnerability/53702281-1bd5-4828-b7a4-9f81cf0b6bb6
- https://plugins.trac.wordpress.org/changeset/2623659
- https://wpscan.com/vulnerability/53702281-1bd5-4828-b7a4-9f81cf0b6bb6
Get alerted when CVE-2021-24935 or the next vulnerability affects your stack