What’s Vulnerable › Vulnerabilities
CVE-2021-24938: WooCommerce Currency Switcher < 1.3.7.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WOOCS WordPress plugin before 1.3.7.1 does not sanitise and escape the key parameter of the woocs_update_profiles_data AJAX action (available to any authenticated user) before outputting it back in the response, leading to a Reflected cross-Site Scripting issue
Affected products
- Woocommerce Currency Switcher: before 1.3.7.1 — fixed in 1.3.7.1
How to fix
Upgrade to a fixed version: Woocommerce Currency Switcher 1.3.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/df8a6f2c-e075-45d5-9262-b4eb63c9351e
- https://wpscan.com/vulnerability/df8a6f2c-e075-45d5-9262-b4eb63c9351e
Get alerted when CVE-2021-24938 or the next vulnerability affects your stack