What’s Vulnerable › Vulnerabilities
CVE-2021-24941: Icegram < 2.0.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.0.5 does not sanitise and escape the message_id parameter of the get_message_action_row AJAX action before outputting it back in an attribute, leading to a reflected Cross-Site Scripting issue
Affected products
- Icegram: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: Icegram 2.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/beca7afd-8f03-4909-bea0-77b63513564b
- https://wpscan.com/vulnerability/beca7afd-8f03-4909-bea0-77b63513564b
Get alerted when CVE-2021-24941 or the next vulnerability affects your stack