What’s Vulnerable › Vulnerabilities
CVE-2021-24948: The Plus Addons for Elementor Pro < 5.0.7 - Sensitive Data Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-200
Description
The Plus Addons for Elementor - Pro WordPress plugin before 5.0.7 does not validate the qvquery parameter of the tp_get_dl_post_info_ajax AJAX action, which could allow unauthenticated users to retrieve sensitive information, such as private and draft posts
Affected products
- posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce: before 5.0.7 — fixed in 5.0.7
How to fix
Upgrade to a fixed version: posimyththemes The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce 5.0.7. Check the vendor advisory for mitigations.
References
- https://roadmap.theplusaddons.com/updates
- https://wpscan.com/vulnerability/2b67005a-476e-4772-b15c-3191911a50b0
- https://roadmap.theplusaddons.com/updates
- https://wpscan.com/vulnerability/2b67005a-476e-4772-b15c-3191911a50b0
Get alerted when CVE-2021-24948 or the next vulnerability affects your stack