What’s Vulnerable › Vulnerabilities
CVE-2021-24963: LiteSpeed Cache < 4.4.4 - Admin+ Reflected Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The LiteSpeed Cache WordPress plugin before 4.4.4 does not escape the qc_res parameter before outputting it back in the JS code of an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- LiteSpeed Technologies LiteSpeed Cache: before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Cache 4.4.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2634373
- https://wpscan.com/vulnerability/7f8b4275-7586-4e04-afd9-d12bdab6ba9b
- https://plugins.trac.wordpress.org/changeset/2634373
- https://wpscan.com/vulnerability/7f8b4275-7586-4e04-afd9-d12bdab6ba9b
Get alerted when CVE-2021-24963 or the next vulnerability affects your stack