What’s Vulnerable › Vulnerabilities
CVE-2021-24964: LiteSpeed Cache < 4.4.4 - IP Check Bypass to Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The LiteSpeed Cache WordPress plugin before 4.4.4 does not properly verify that requests are coming from QUIC.cloud servers, allowing attackers to make requests to certain endpoints by using a specific X-Forwarded-For header value. In addition, one of the endpoint could be used to set CSS code if a setting is enabled, which will then be output in some pages without being sanitised and escaped. Combining those two issues, an unauthenticated attacker could put Cross-Site Scripting payloads in pages visited by users.
Affected products
- LiteSpeed Technologies LiteSpeed Cache: before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Cache 4.4.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e9966b3e-2eb9-4d70-8c18-6a829b4827cc
- https://wpscan.com/vulnerability/e9966b3e-2eb9-4d70-8c18-6a829b4827cc
Get alerted when CVE-2021-24964 or the next vulnerability affects your stack