What’s Vulnerable › Vulnerabilities
CVE-2021-24971: WP Responsive Menu < 3.1.7.1 - Subscriber+ Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Responsive Menu WordPress plugin before 3.1.7.1 does not have capability and CSRF checks in the wpr_live_update AJAX action, as well as do not sanitise and escape some of the data submitted. As a result, any authenticated, such as subscriber could update the plugin's settings and perform Cross-Site Scripting attacks against all visitor and users on the frontend
Affected products
- WP Responsive Menu: before 3.1.7.1 — fixed in 3.1.7.1
How to fix
Upgrade to a fixed version: WP Responsive Menu 3.1.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/661cb7e3-d7bd-4bc1-bf78-bdb4ba9610d7
- https://wpscan.com/vulnerability/661cb7e3-d7bd-4bc1-bf78-bdb4ba9610d7
Get alerted when CVE-2021-24971 or the next vulnerability affects your stack