What’s Vulnerable › Vulnerabilities
CVE-2021-24974: Product Feed PRO for WooCommerce < 11.0.7 - Subscriber+ Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Product Feed PRO for WooCommerce WordPress plugin before 11.0.7 does not have authorisation and CSRF check in some of its AJAX actions, allowing any authenticated users to call then, which could lead to Stored Cross-Site Scripting issue (which will be triggered in the admin dashboard) due to the lack of escaping.
Affected products
- AdTribes.io Product Feed PRO for WooCommerce: before 11.0.7 — fixed in 11.0.7
How to fix
Upgrade to a fixed version: AdTribes.io Product Feed PRO for WooCommerce 11.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8ed549fe-7d27-4a7a-b226-c20252964b29
- https://wpscan.com/vulnerability/8ed549fe-7d27-4a7a-b226-c20252964b29
Get alerted when CVE-2021-24974 or the next vulnerability affects your stack