What’s Vulnerable › Vulnerabilities
CVE-2021-24975: NextScripts: Social Networks Auto-Poster < 4.3.24 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.24 does not sanitise and escape logged requests before outputting them in the related admin dashboard, leading to an Unauthenticated Stored Cross-Site Scripting issue
Affected products
- NextScripts: Social Networks Auto-Poster: before 4.3.24 — fixed in 4.3.24
How to fix
Upgrade to a fixed version: NextScripts: Social Networks Auto-Poster 4.3.24. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2650138
- https://wpscan.com/vulnerability/b99dae3d-8230-4427-adc5-4ef9cbfb8ba1
- https://plugins.trac.wordpress.org/changeset/2650138
- https://wpscan.com/vulnerability/b99dae3d-8230-4427-adc5-4ef9cbfb8ba1
Get alerted when CVE-2021-24975 or the next vulnerability affects your stack