What’s Vulnerable › Vulnerabilities
CVE-2021-24977: Use Any Font < 6.2.1 - Unauthenticated Arbitrary CSS Appending
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The Use Any Font | Custom Font Uploader WordPress plugin before 6.2.1 does not have any authorisation checks when assigning a font, allowing unauthenticated users to sent arbitrary CSS which will then be processed by the frontend for all users. Due to the lack of sanitisation and escaping in the backend, it could also lead to Stored XSS issues
Affected products
- Dnesscarkey Use Any Font | Custom Font Uploader (WordPress plugin): before 6.2.1 — fixed in 6.2.1
How to fix
Upgrade to a fixed version: Dnesscarkey Use Any Font | Custom Font Uploader (WordPress plugin) 6.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/739831e3-cdfb-4a22-9abf-6c594d7e3d75
- https://wpscan.com/vulnerability/739831e3-cdfb-4a22-9abf-6c594d7e3d75
Get alerted when CVE-2021-24977 or the next vulnerability affects your stack