What’s Vulnerable › Vulnerabilities
CVE-2021-24979: Paid Memberships Pro < 2.6.6 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Paid Memberships Pro WordPress plugin before 2.6.6 does not escape the s parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- Paid Memberships Pro: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: Paid Memberships Pro 2.6.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2632369/paid-memberships-pro/tags/2.6.6/adminpages/discountcodes.php
- https://wpscan.com/vulnerability/fc011990-4ec1-4553-901d-4ff1f482cb79
- https://plugins.trac.wordpress.org/changeset/2632369/paid-memberships-pro/tags/2.6.6/adminpages/discountcodes.php
- https://wpscan.com/vulnerability/fc011990-4ec1-4553-901d-4ff1f482cb79
Get alerted when CVE-2021-24979 or the next vulnerability affects your stack