What’s Vulnerable › Vulnerabilities
CVE-2021-24980: Gwolle Guestbook < 4.2.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gwolle Guestbook WordPress plugin before 4.2.0 does not sanitise and escape the gwolle_gb_user_email parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting issue in an admin page
Affected products
- Gwolle Guestbook Plugin: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: Gwolle Guestbook Plugin 4.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e50bcb39-9a01-433f-81b3-fd4018672b85
- https://wpscan.com/vulnerability/e50bcb39-9a01-433f-81b3-fd4018672b85
Get alerted when CVE-2021-24980 or the next vulnerability affects your stack