What’s Vulnerable › Vulnerabilities
CVE-2021-24984: WPFront User Role Editor < 3.2.1.11184 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPFront User Role Editor WordPress plugin before 3.2.1.11184 does not sanitise and escape the changes-saved parameter before outputting it back in the admin dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- syammohanm WPFront User Role Editor: before 3.2.1.11184 — fixed in 3.2.1.11184
How to fix
Upgrade to a fixed version: syammohanm WPFront User Role Editor 3.2.1.11184. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/96bb2fba-4b18-4c29-8344-3ba4d2f06a19
- https://wpscan.com/vulnerability/96bb2fba-4b18-4c29-8344-3ba4d2f06a19
Get alerted when CVE-2021-24984 or the next vulnerability affects your stack