What’s Vulnerable › Vulnerabilities
CVE-2021-24985: Easy Forms for Mailchimp < 6.8.6 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Forms for Mailchimp WordPress plugin before 6.8.6 does not sanitise and escape the field_name and field_type parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting issues
Affected products
- Easy Forms for Mailchimp: before 6.8.6 — fixed in 6.8.6
How to fix
Upgrade to a fixed version: Easy Forms for Mailchimp 6.8.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2646017
- https://wpscan.com/vulnerability/50be0ebf-fe6d-41e5-8af9-0d74f33aeb57
- https://plugins.trac.wordpress.org/changeset/2646017
- https://wpscan.com/vulnerability/50be0ebf-fe6d-41e5-8af9-0d74f33aeb57
Get alerted when CVE-2021-24985 or the next vulnerability affects your stack