What’s Vulnerable › Vulnerabilities
CVE-2021-24986: Post Grid < 2.1.16 - Reflected Cross-Site Scripting via keyword
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Grid WordPress plugin before 2.1.16 does not escape the keyword parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting in pages containing a Post Grid with a search form
Affected products
- pickplugins Post Grid: before 2.1.16 — fixed in 2.1.16
How to fix
Upgrade to a fixed version: pickplugins Post Grid 2.1.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/51e57f25-b8b2-44ca-9162-d7328eac64eb
- https://wpscan.com/vulnerability/51e57f25-b8b2-44ca-9162-d7328eac64eb
Get alerted when CVE-2021-24986 or the next vulnerability affects your stack