What’s Vulnerable › Vulnerabilities
CVE-2021-24988: WP RSS Aggregator < 4.19.3 - Subscriber+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP RSS Aggregator WordPress plugin before 4.19.3 does not sanitise and escape data before outputting it in the System Info admin dashboard, which could lead to a Stored XSS issue due to the wprss_dismiss_addon_notice AJAX action missing authorisation and CSRF checks, allowing any authenticated users, such as subscriber to call it and set a malicious payload in the addon parameter.
Affected products
- WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More: before 4.19.3 — fixed in 4.19.3
How to fix
Upgrade to a fixed version: WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More 4.19.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0742483b-6314-451b-a63a-536fd1e14845
- https://wpscan.com/vulnerability/0742483b-6314-451b-a63a-536fd1e14845
Get alerted when CVE-2021-24988 or the next vulnerability affects your stack