What’s Vulnerable › Vulnerabilities
CVE-2021-24991: WooCommerce PDF Invoices & Packing Slips < 2.10.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce PDF Invoices & Packing Slips WordPress plugin before 2.10.5 does not escape the tab and section parameters before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting in the admin dashboard
Affected products
- wpovernight PDF Invoices & Packing Slips for WooCommerce: before 2.10.5 — fixed in 2.10.5
How to fix
Upgrade to a fixed version: wpovernight PDF Invoices & Packing Slips for WooCommerce 2.10.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/88e706df-ae03-4665-94a3-db226e1f31a9
- https://wpscan.com/vulnerability/88e706df-ae03-4665-94a3-db226e1f31a9
Get alerted when CVE-2021-24991 or the next vulnerability affects your stack