What’s Vulnerable › Vulnerabilities
CVE-2021-24992: Buttonizer - Smart Floating Action Button < 2.5.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smart Floating / Sticky Buttons WordPress plugin before 2.5.5 does not sanitise and escape some parameter before outputting them in attributes and page, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer: before 2.5.5 — fixed in 2.5.5
How to fix
Upgrade to a fixed version: Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer 2.5.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/db0b9480-2ff4-423c-a745-68e983ffa12b
- https://wpscan.com/vulnerability/db0b9480-2ff4-423c-a745-68e983ffa12b
Get alerted when CVE-2021-24992 or the next vulnerability affects your stack