What’s Vulnerable › Vulnerabilities
CVE-2021-24994: WPvivid Backup and Migration Plugin < 0.9.69 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Migration, Backup, Staging WordPress plugin before 0.9.69 does not have authorisation when adding remote storages, and does not sanitise as well as escape a parameter from such unauthenticated requests before outputting it in admin page, leading to a Stored Cross-Site Scripting issue
Affected products
- wpvividplugins WPvivid — Backup, Migration & Staging: before 0.9.69 — fixed in 0.9.69
How to fix
Upgrade to a fixed version: wpvividplugins WPvivid — Backup, Migration & Staging 0.9.69. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ea74257a-f6b0-49e9-a81f-53c0eb81b1da
- https://wpscan.com/vulnerability/ea74257a-f6b0-49e9-a81f-53c0eb81b1da
Get alerted when CVE-2021-24994 or the next vulnerability affects your stack