What’s Vulnerable › Vulnerabilities
CVE-2021-24995: HTML5 Responsive FAQ <= 2.8.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The HTML5 Responsive FAQ WordPress plugin through 2.8.5 does not properly sanitise and escape some of its settings, which could allow a high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- HTML5 Responsive FAQ: before 2.8.5 — fixed in 2.8.5
How to fix
Upgrade to a fixed version: HTML5 Responsive FAQ 2.8.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3caf0de0-57f2-4c87-8713-d00a7db9eeef
- https://wpscan.com/vulnerability/3caf0de0-57f2-4c87-8713-d00a7db9eeef
Get alerted when CVE-2021-24995 or the next vulnerability affects your stack