What’s Vulnerable › Vulnerabilities
CVE-2021-24996: IDPay for Contact Form 7 <= 2.1.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The IDPay for Contact Form 7 WordPress plugin through 2.1.2 does not sanitise and escape the idpay_error parameter before outputting it back in the page leading to a Reflected Cross-Site Scripting
Affected products
- IDPay for Contact Form 7: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: IDPay for Contact Form 7 2.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6ee14423-f7ff-4433-987a-a1a6b7bd65e3
- https://wpscan.com/vulnerability/6ee14423-f7ff-4433-987a-a1a6b7bd65e3
Get alerted when CVE-2021-24996 or the next vulnerability affects your stack