What’s Vulnerable › Vulnerabilities
CVE-2021-24997: WP Guppy < 1.3 - Sensitive Information Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Guppy WordPress plugin before 1.3 does not have any authorisation in some of the REST API endpoints, allowing any user to call them and could lead to sensitive information disclosure, such as usernames and chats between users, as well as be able to send messages as an arbitrary user
Affected products
- WP Guppy: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: WP Guppy 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/Keyvanhardani/WP-Guppy-A-live-chat-WP-JSON-API-Sensitive-Information-Disclosure
- https://wpscan.com/vulnerability/747e6c7e-a167-4d82-b6e6-9e8613f0e900
- https://github.com/Keyvanhardani/WP-Guppy-A-live-chat-WP-JSON-API-Sensitive-Information-Disclosure
- https://wpscan.com/vulnerability/747e6c7e-a167-4d82-b6e6-9e8613f0e900
Get alerted when CVE-2021-24997 or the next vulnerability affects your stack