What’s Vulnerable › Vulnerabilities
CVE-2021-25000: Booster for WooCommerce < 5.4.9 - Reflected Cross-Site Scripting in General Module
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Booster for WooCommerce WordPress plugin before 5.4.9 does not sanitise and escape the wcj_delete_role parameter before outputting back in the admin dashboard when the General module is enabled, leading to a Reflected Cross-Site Scripting issue
Affected products
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 5.4.9 — fixed in 5.4.9
How to fix
Upgrade to a fixed version: pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 5.4.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bc167b3a-24ee-4988-9934-189b6216ce40
- https://wpscan.com/vulnerability/bc167b3a-24ee-4988-9934-189b6216ce40
Get alerted when CVE-2021-25000 or the next vulnerability affects your stack