What’s Vulnerable › Vulnerabilities
CVE-2021-25008: Code Snippets < 2.14.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Code Snippets WordPress plugin before 2.14.3 does not escape the snippets-safe-mode parameter before outputting it back in attributes, leading to a Reflected Cross-Site Scripting issue
Affected products
- Code Snippets: before 2.14.3 — fixed in 2.14.3
How to fix
Upgrade to a fixed version: Code Snippets 2.14.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cb232354-f74d-48bb-b437-7bdddd1df42a
- https://wpscan.com/vulnerability/cb232354-f74d-48bb-b437-7bdddd1df42a
Get alerted when CVE-2021-25008 or the next vulnerability affects your stack