What’s Vulnerable › Vulnerabilities
CVE-2021-25015: myCred < 2.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The myCred WordPress plugin before 2.4 does not sanitise and escape the search query before outputting it back in the history dashboard page, leading to a Reflected Cross-Site Scripting issue
Affected products
- saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred 2.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2648350/mycred
- https://wpscan.com/vulnerability/7608829d-2820-49e2-a10e-e93eb3005f68
- https://plugins.trac.wordpress.org/changeset/2648350/mycred
- https://wpscan.com/vulnerability/7608829d-2820-49e2-a10e-e93eb3005f68
Get alerted when CVE-2021-25015 or the next vulnerability affects your stack