What’s Vulnerable › Vulnerabilities
CVE-2021-25016: Chaty < 2.8.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Chaty WordPress plugin before 2.8.3 and Chaty Pro WordPress plugin before 2.8.2 do not sanitise and escape the search parameter before outputting it back in the admin dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- Premio Chaty: before 2.8.3 — fixed in 2.8.3
- Premio Chaty Pro: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: Premio Chaty 2.8.3; Premio Chaty Pro 2.8.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b5035987-6227-4fc6-bc45-1e8016e5c4c0
- https://wpscan.com/vulnerability/b5035987-6227-4fc6-bc45-1e8016e5c4c0
Get alerted when CVE-2021-25016 or the next vulnerability affects your stack