What’s Vulnerable › Vulnerabilities
CVE-2021-25017: Tutor LMS < 1.9.12 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tutor LMS WordPress plugin before 1.9.12 does not escape the search parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.9.12 — fixed in 1.9.12
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.9.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2643821
- https://wpscan.com/vulnerability/2d0c4872-a341-4974-926c-10b094a5d13c
- https://plugins.trac.wordpress.org/changeset/2643821
- https://wpscan.com/vulnerability/2d0c4872-a341-4974-926c-10b094a5d13c
Get alerted when CVE-2021-25017 or the next vulnerability affects your stack