What’s Vulnerable › Vulnerabilities
CVE-2021-25018: PPOM for WooCommerce < 24.0 - Subscriber+ Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-862
Description
The PPOM for WooCommerce WordPress plugin before 24.0 does not have authorisation and CSRF checks in the ppom_settings_panel_action AJAX action, allowing any authenticated to call it and set arbitrary settings. Furthermore, due to the lack of sanitisation and escaping, it could lead to Stored XSS issues
Affected products
- PPOM for WooCommerce: before 24.0 — fixed in 24.0
How to fix
Upgrade to a fixed version: PPOM for WooCommerce 24.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9e092aad-0b36-45a9-8987-8d904b34fbb2
- https://wpscan.com/vulnerability/9e092aad-0b36-45a9-8987-8d904b34fbb2
Get alerted when CVE-2021-25018 or the next vulnerability affects your stack