What’s Vulnerable › Vulnerabilities
CVE-2021-25024: Event Calendar < 1.1.51 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The EventCalendar WordPress plugin before 1.1.51 does not escape some user input before outputting it back in attributes, leading to Reflected Cross-SIte Scripting issues
Affected products
- EventCalendar: before 1.1.51 — fixed in 1.1.51
How to fix
Upgrade to a fixed version: EventCalendar 1.1.51. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/08864b76-d898-4dfe-970d-d7cc1b1115a7
- https://wpscan.com/vulnerability/08864b76-d898-4dfe-970d-d7cc1b1115a7
Get alerted when CVE-2021-25024 or the next vulnerability affects your stack