What’s Vulnerable › Vulnerabilities
CVE-2021-25025: Event Calendar < 1.1.51 - Subscriber+ Event Creation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The EventCalendar WordPress plugin before 1.1.51 does not have proper authorisation and CSRF checks in the add_calendar_event AJAX actions, allowing users with a role as low as subscriber to create events
Affected products
- EventCalendar: before 1.1.51 — fixed in 1.1.51
How to fix
Upgrade to a fixed version: EventCalendar 1.1.51. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/24fb4eb4-9fe1-4433-8844-8904eaf13c0e
- https://wpscan.com/vulnerability/24fb4eb4-9fe1-4433-8844-8904eaf13c0e
Get alerted when CVE-2021-25025 or the next vulnerability affects your stack