What’s Vulnerable › Vulnerabilities
CVE-2021-25026: Patreon WordPress < 1.8.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Patreon WordPress plugin before 1.8.2 does not sanitise and escape the field "Custom Patreon Page name", which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Patreon WordPress: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: Patreon WordPress 1.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2682069
- https://wpscan.com/vulnerability/02756dd3-832a-4846-b9e1-a34f148b5cfe
- https://plugins.trac.wordpress.org/changeset/2682069
- https://wpscan.com/vulnerability/02756dd3-832a-4846-b9e1-a34f148b5cfe
Get alerted when CVE-2021-25026 or the next vulnerability affects your stack