What’s Vulnerable › Vulnerabilities
CVE-2021-25030: Events Made Easy < 2.2.36 - Subscriber+ SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-89
Description
The Events Made Easy WordPress plugin before 2.2.36 does not sanitise and escape the search_text parameter before using it in a SQL statement via the eme_searchmail AJAX action, available to any authenticated users. As a result, users with a role as low as subscriber can call it and perform SQL injection attacks
Affected products
- Events Made Easy: before 2.2.36 — fixed in 2.2.36
How to fix
Upgrade to a fixed version: Events Made Easy 2.2.36. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bc7058b1-ca93-4c45-9ced-7848c7ae4150
- https://wpscan.com/vulnerability/bc7058b1-ca93-4c45-9ced-7848c7ae4150
Get alerted when CVE-2021-25030 or the next vulnerability affects your stack