What’s Vulnerable › Vulnerabilities
CVE-2021-25034: WP User < 7.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP User WordPress plugin before 7.0 does not sanitise and escape some parameters in pages where the [wp_user] shortcode is used, leading to Reflected Cross-Site Scripting issues
Affected products
- WP User: before 7.0 — fixed in 7.0
How to fix
Upgrade to a fixed version: WP User 7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c4e50dd2-450f-413d-b15f-ece413e42157
- https://wpscan.com/vulnerability/c4e50dd2-450f-413d-b15f-ece413e42157
Get alerted when CVE-2021-25034 or the next vulnerability affects your stack