What’s Vulnerable › Vulnerabilities
CVE-2021-25040: Booking Calendar < 8.9.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Booking Calendar WordPress plugin before 8.9.2 does not sanitise and escape the booking_type parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- codepeople Booking Calendar Contact Form: before 8.9.2 — fixed in 8.9.2
How to fix
Upgrade to a fixed version: codepeople Booking Calendar Contact Form 8.9.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3ed821a6-c3e2-4964-86f8-d14c4a54708a
- https://wpscan.com/vulnerability/3ed821a6-c3e2-4964-86f8-d14c4a54708a
Get alerted when CVE-2021-25040 or the next vulnerability affects your stack