What’s Vulnerable › Vulnerabilities
CVE-2021-25043: WOOCS < 1.3.7.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The WOOCS WordPress plugin before 1.3.7.3 does not sanitise and escape the custom_prices parameter before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue
Affected products
- PluginUS Woocommerce Currency Switcher: before 1.3.7.3 — fixed in 1.3.7.3
How to fix
Upgrade to a fixed version: PluginUS Woocommerce Currency Switcher 1.3.7.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2640621/woocommerce-currency-switcher
- https://wpscan.com/vulnerability/8601bd21-becf-4809-8c11-d053d1121eae
- https://plugins.trac.wordpress.org/changeset/2640621/woocommerce-currency-switcher
- https://wpscan.com/vulnerability/8601bd21-becf-4809-8c11-d053d1121eae
Get alerted when CVE-2021-25043 or the next vulnerability affects your stack