What’s Vulnerable › Vulnerabilities
CVE-2021-25053: WP Coder < 2.5.2 - RFI leading to RCE via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Coder WordPress plugin before 2.5.2 within the wow-company admin menu page allows to include() arbitrary file with PHP extension (as well as with data:// or http:// protocols), thus leading to CSRF RCE.
Affected products
- WP Coder – add custom html, css and js code: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: WP Coder – add custom html, css and js code 2.5.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2641650/wp-coder
- https://wpscan.com/vulnerability/a5448599-64de-43b0-b04d-c6492366eab1
- https://plugins.trac.wordpress.org/changeset/2641650/wp-coder
- https://wpscan.com/vulnerability/a5448599-64de-43b0-b04d-c6492366eab1
Get alerted when CVE-2021-25053 or the next vulnerability affects your stack