What’s Vulnerable › Vulnerabilities
CVE-2021-25056: Ninja Forms < 3.6.10 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Forms Contact Form WordPress plugin before 3.6.10 does not sanitise and escape field labels, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.6.10 — fixed in 3.6.10
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.6.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/795acab2-f621-4662-834b-ebb6205ef7de
- https://wpscan.com/vulnerability/795acab2-f621-4662-834b-ebb6205ef7de
Get alerted when CVE-2021-25056 or the next vulnerability affects your stack