What’s Vulnerable › Vulnerabilities
CVE-2021-25061: WP Booking System – Booking Calendar < 2.0.15 - Authenticated Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Booking System WordPress plugin before 2.0.15 was affected by a reflected xss in wp-booking-system on the wpbs-calendars admin page.
Affected products
- murgroland WP Booking System – Booking Calendar: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: murgroland WP Booking System – Booking Calendar 2.0.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2643776/wp-booking-system
- https://wpscan.com/vulnerability/bd9dc754-08a4-4bfc-8dda-3f5c0e070f7e
- https://plugins.trac.wordpress.org/changeset/2643776/wp-booking-system
- https://wpscan.com/vulnerability/bd9dc754-08a4-4bfc-8dda-3f5c0e070f7e
Get alerted when CVE-2021-25061 or the next vulnerability affects your stack