What’s Vulnerable › Vulnerabilities
CVE-2021-25072: NextScripts: Social Networks Auto-Poster < 4.3.25 - Arbitrary Post Deletion via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-352
Description
The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.25 does not have CSRF check in place when deleting items, allowing attacker to make a logged in admin delete arbitrary posts via a CSRF attack
Affected products
- NextScripts: Social Networks Auto-Poster: before 4.3.25 — fixed in 4.3.25
How to fix
Upgrade to a fixed version: NextScripts: Social Networks Auto-Poster 4.3.25. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/53d2c61d-ce73-40e0-a113-9d76d8fecc91
- https://wpscan.com/vulnerability/53d2c61d-ce73-40e0-a113-9d76d8fecc91
Get alerted when CVE-2021-25072 or the next vulnerability affects your stack