What’s Vulnerable › Vulnerabilities
CVE-2021-25075: Duplicate Page or Post < 1.5.1 - Arbitrary Settings Update to Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-862
Description
The Duplicate Page or Post WordPress plugin before 1.5.1 does not have any authorisation and has a flawed CSRF check in the wpdevart_duplicate_post_parametrs_save_in_db AJAX action, allowing any authenticated users, such as subscriber to call it and change the plugin's settings, or perform such attack via CSRF. Furthermore, due to the lack of escaping, this could lead to Stored Cross-Site Scripting issues
Affected products
- Duplicate Page or Post: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Duplicate Page or Post 1.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/db5a0431-af4d-45b7-be4e-36b6c90a601b
- https://wpscan.com/vulnerability/db5a0431-af4d-45b7-be4e-36b6c90a601b
Get alerted when CVE-2021-25075 or the next vulnerability affects your stack