What’s Vulnerable › Vulnerabilities
CVE-2021-25076: WP User Frontend < 3.5.26 - SQL Injection to Reflected Cross-Site Scripting
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP User Frontend WordPress plugin before 3.5.26 does not validate and escape the status parameter before using it in a SQL statement in the Subscribers dashboard, leading to an SQL injection. Due to the lack of sanitisation and escaping, this could also lead to Reflected Cross-Site Scripting
Affected products
- weDevs WP User Frontend: before 3.5.26 — fixed in 3.5.26
How to fix
Upgrade to a fixed version: weDevs WP User Frontend 3.5.26. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166071/WordPress-WP-User-Frontend-3.5.25-SQL-Injection.html
- https://plugins.trac.wordpress.org/changeset/2648715
- https://wpscan.com/vulnerability/6d3eeba6-5560-4380-a6e9-f008a9112ac6
- http://packetstormsecurity.com/files/166071/WordPress-WP-User-Frontend-3.5.25-SQL-Injection.html
- https://plugins.trac.wordpress.org/changeset/2648715
- https://wpscan.com/vulnerability/6d3eeba6-5560-4380-a6e9-f008a9112ac6
Get alerted when CVE-2021-25076 or the next vulnerability affects your stack