What’s Vulnerable › Vulnerabilities
CVE-2021-25077: Store Toolkit for WooCommerce < 2.3.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Store Toolkit for WooCommerce WordPress plugin before 2.3.2 does not sanitise and escape the tab parameter before outputting it back in an admin page in an error message, leading to a Reflected Cross-Site Scripting
Affected products
- Store Toolkit for WooCommerce: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: Store Toolkit for WooCommerce 2.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2654503
- https://wpscan.com/vulnerability/53868650-aba0-4d07-89d2-a998bb0ee5f6
- https://plugins.trac.wordpress.org/changeset/2654503
- https://wpscan.com/vulnerability/53868650-aba0-4d07-89d2-a998bb0ee5f6
Get alerted when CVE-2021-25077 or the next vulnerability affects your stack