What’s Vulnerable › Vulnerabilities
CVE-2021-25080: Contact Form Entries < 1.1.7 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form Entries WordPress plugin before 1.1.7 does not validate, sanitise and escape the IP address retrieved via headers such as CLIENT-IP and X-FORWARDED-FOR, allowing unauthenticated attackers to perform Cross-Site Scripting attacks against logged in admins viewing the created entry
Affected products
- Contact Form Entries – Contact Form 7, WPforms and more: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Contact Form Entries – Contact Form 7, WPforms and more 1.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2450335
- https://wpscan.com/vulnerability/acd3d98a-aab8-49be-b77e-e8c6ede171ac
- https://plugins.trac.wordpress.org/changeset/2450335
- https://wpscan.com/vulnerability/acd3d98a-aab8-49be-b77e-e8c6ede171ac
Get alerted when CVE-2021-25080 or the next vulnerability affects your stack