What’s Vulnerable › Vulnerabilities
CVE-2021-25082: Popup Builder < 4.0.7 - LFI to RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-22
Description
The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR
Affected products
- Popup Builder: before 4.0.7 — fixed in 4.0.7
How to fix
Upgrade to a fixed version: Popup Builder 4.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2659117
- https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132
- https://plugins.trac.wordpress.org/changeset/2659117
- https://wpscan.com/vulnerability/0f90f10c-4b0a-46da-ac1f-aa6a03312132
Get alerted when CVE-2021-25082 or the next vulnerability affects your stack