What’s Vulnerable › Vulnerabilities
CVE-2021-25088: Google XML Sitemaps < 4.1.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The XML Sitemaps WordPress plugin before 4.1.3 does not sanitise and escape a settings before outputting it in the Debug page, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- XML Sitemaps: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: XML Sitemaps 4.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/820c51d6-186e-4d63-b4a7-bd0a59c02cc8
- https://wpscan.com/vulnerability/820c51d6-186e-4d63-b4a7-bd0a59c02cc8
Get alerted when CVE-2021-25088 or the next vulnerability affects your stack