What’s Vulnerable › Vulnerabilities
CVE-2021-25089: UpdraftPlus < 1.16.69 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The UpdraftPlus WordPress Backup Plugin WordPress plugin before 1.16.69 does not sanitise and escape the updraft_restore parameter before outputting it back in the Restore page, leading to a Reflected Cross-Site Scripting
Affected products
- UpdraftPlus WordPress Backup Plugin: before 1.16.69 — fixed in 1.16.69
How to fix
Upgrade to a fixed version: UpdraftPlus WordPress Backup Plugin 1.16.69. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5adb977e-f7bf-4d36-b625-87bc23d379c8
- https://wpscan.com/vulnerability/5adb977e-f7bf-4d36-b625-87bc23d379c8
Get alerted when CVE-2021-25089 or the next vulnerability affects your stack